Discussion about development tools and environments, such as STLink, OpenOCD, arm-gcc, Eclipse, Qt Creator and Visual Studio.
no avatar
User

jpalovick

Posts

7

Joined

Sat Oct 04, 2014 12:55 pm

Build Environment - Ubuntu 14.04.1 64 bit

by jpalovick » Tue Mar 03, 2015 9:19 pm

I didn't get very far. I'm trying to install the ia-32libs and I am getting a failure. Does anyone have advice on how to rectify this?

Thanks in advance,

Joe
User avatar
User

h3nk

Posts

37

Joined

Sat Mar 01, 2014 5:11 pm

Location

Germany

Re: Build Environment - Ubuntu 14.04.1 64 bit

by h3nk » Wed Mar 04, 2015 4:25 pm

If you provide us with a bit more info on the error you're getting, someone might be able to help you :)
no avatar
User

jpalovick

Posts

7

Joined

Sat Oct 04, 2014 12:55 pm

Re: Build Environment - Ubuntu 14.04.1 64 bit

by jpalovick » Wed Mar 04, 2015 5:44 pm

Sure and thanks. :)

As I follow the instructions for creating the building the development environment and you arrive at the step to run uname -m. Since I am on a 64 bit architecture I then run

sudo apt-get install ia32-libs

and when I attempt to install the 32 bit libraries I get a failure saying the library doesn't exist and it offers some potential alternate libraries to install. I did some quick searches and it seems like that list does not solve the problem.

I'm not on the machine now so I don't have the exact error, but the steps above are where I am seeing the failure. Let me know if you need to see the specific error

Thanks in advance,

Joe
User avatar
User

metRo_

Posts

178

Joined

Tue Mar 04, 2014 5:26 pm

Re: Build Environment - Ubuntu 14.04.1 64 bit

by metRo_ » Thu Mar 05, 2015 10:34 am

jpalovick wrote:Sure and thanks. :)

As I follow the instructions for creating the building the development environment and you arrive at the step to run uname -m. Since I am on a 64 bit architecture I then run

sudo apt-get install ia32-libs

and when I attempt to install the 32 bit libraries I get a failure saying the library doesn't exist and it offers some potential alternate libraries to install. I did some quick searches and it seems like that list does not solve the problem.

I'm not on the machine now so I don't have the exact error, but the steps above are where I am seeing the failure. Let me know if you need to see the specific error

Thanks in advance,

Joe


ia32-lib isn't no more on the repo. There are some soltuions but you need to search for it, I can't remember right now :s
no avatar
User

jpalovick

Posts

7

Joined

Sat Oct 04, 2014 12:55 pm

Re: Build Environment - Ubuntu 14.04.1 64 bit

by jpalovick » Thu Mar 05, 2015 12:47 pm

Thanks. I gathered it was no longer supported from the error message and did some looking around to find the solution but it was very unclear. I suppose it is easier to run 32-bit Ubuntu in a VM. I was hoping not to turn the creation of the build environment into a science project, but may give it another look when I get a chance.
no avatar
User

jpalovick

Posts

7

Joined

Sat Oct 04, 2014 12:55 pm

Re: Build Environment - Ubuntu 14.04.1 64 bit

by jpalovick » Fri Mar 06, 2015 10:49 pm

I got the GCS to build. I found the correct instruction in this thread http://forum.taulabs.org/viewtopic.php?f=19&t=455. I'm not sure how the Wiki is maintained, but if it is updated the instructions on the Linux build for the step

sudo apt-get ia32-libs

should be replaced by

sudo apt-get lib32z1 lib32ncurses5 lib32bz2-1.0

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB ® | phpBB3 Style by KomiDesign