Discussion about development tools and environments, such as STLink, OpenOCD, arm-gcc, Eclipse, Qt Creator and Visual Studio.

Board not recognized on OSX?

no avatar
User

crazymao

Posts

32

Joined

Sat Feb 07, 2015 7:28 am

Board not recognized on OSX?

by crazymao » Sat Feb 07, 2015 7:37 am

Hi guys, I just bought the Quanton dev board and I'm trying to set it up on my OSX machine however I'm running into some issues. Firstly let me say that I know that everything is okay with the board, I connected it to the GCS on my Windows Virtual Machine and it recognized it just fine and everything worked, almost, it crashed when I tried to save a coax configuration, but that's besides the point. I would prefer to set it up on my local OSX machine however the board doesn't get recognized. I tried with the GCS and it sees that something is connected to the USB port, but it doesn't see that it's a Quanton board. I tried without the GCS by just running make, and I got the following errors, again leading me to believe that it's simply not recognizing my board:
Code: Select all
Open On-Chip Debugger 0.8.0 (2015-02-06-23:27)
Licensed under GNU GPL v2
For bug reports, read
   http://openocd.sourceforge.net/doc/doxygen/bugs.html
debug_level: 0
adapter speed: 1000 kHz
Error: open failed
in procedure 'transport'
in procedure 'init'
make[1]: *** [program] Error 1
make: *** [bl_quanton_program] Error 2

Has anyone else had this issue before, or does anyone have any insight into what I might try to fix it? Thanks a lot! I'll continue trying to find answers by myself but any insight will be appreciated.
User avatar
User

guilhermito

Posts

155

Joined

Mon Jan 13, 2014 9:16 pm

Re: Board not recognized on OSX?

by guilhermito » Sat Feb 07, 2015 2:42 pm

What was the command that gave you that output? Looks like it is trying to debug the board
no avatar
User

crazymao

Posts

32

Joined

Sat Feb 07, 2015 7:28 am

Re: Board not recognized on OSX?

by crazymao » Sat Feb 07, 2015 3:14 pm

I get that message when I try to do anything with the board:
Code: Select all
make bl_quanton_program
make fw_quanton_program
make ef_quanton_program
User avatar
User

guilhermito

Posts

155

Joined

Mon Jan 13, 2014 9:16 pm

Re: Board not recognized on OSX?

by guilhermito » Sat Feb 07, 2015 9:58 pm

crazymao wrote:I get that message when I try to do anything with the board:
Code: Select all
make bl_quanton_program
make fw_quanton_program
make ef_quanton_program

Those commands are to be used with an swd programming interface not with a normal USB connection. What exactly are you trying to achieve?
no avatar
User

crazymao

Posts

32

Joined

Sat Feb 07, 2015 7:28 am

Re: Board not recognized on OSX?

by crazymao » Sat Feb 07, 2015 10:02 pm

guilhermito wrote:Those commands are to be used with an swd programming interface not with a normal USB connection. What exactly are you trying to achieve?


I'm trying to figure out how to upload firmware to the board without the use of the GCS. It must be possible via USB since the GCS can do it?
User avatar
User

peabody124

Posts

1339

Joined

Tue Feb 18, 2014 12:33 pm

Re: Board not recognized on OSX?

by peabody124 » Sun Feb 08, 2015 10:24 pm

Well you can use dfu-util to upload via USB using the built in bootloader. However, that requires shorting the BOOT0 to ground, but unfortunately that isn't available on Quanton.
no avatar
User

crazymao

Posts

32

Joined

Sat Feb 07, 2015 7:28 am

Re: Board not recognized on OSX?

by crazymao » Mon Feb 09, 2015 1:14 am

peabody124 wrote:Well you can use dfu-util to upload via USB using the built in bootloader. However, that requires shorting the BOOT0 to ground, but unfortunately that isn't available on Quanton.

So how does the GCS accomplish it, or am I missing something here.

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB ® | phpBB3 Style by KomiDesign
cron