Development discussion of TauLabs software such as ground control stations, antenna trackers etc.
User avatar
User

strips

Posts

49

Joined

Sat Sep 20, 2014 9:44 pm

Location

Norway, Åros

Problem connecting Sparky to Mac

by strips » Fri Apr 10, 2015 6:13 am

The first time I tried to connect my Sparky was on my Macbook Pro with USB3.

I see the "Sparky" dev in System Information and get a Serial: usbmodem dev in GCS. GCS doesn't want to connect to it.

Trying windows XP in VirtualBox on the same Mac worked right away.

So are there any drivers needed for Mac? The device had rw-rw-r in permissions. Any tips for my next try tonight?
User avatar
User

peabody124

Posts

1339

Joined

Tue Feb 18, 2014 12:33 pm

Re: Problem connecting Sparky to Mac

by peabody124 » Fri Apr 10, 2015 5:15 pm

You shouldn't need any drivers on Mac. In the device info see if the serial number ends in. +FW or +BL. Where did you get it from?
User avatar
User

strips

Posts

49

Joined

Sat Sep 20, 2014 9:44 pm

Location

Norway, Åros

Re: Problem connecting Sparky to Mac

by strips » Tue Apr 14, 2015 6:49 pm

peabody124 wrote:You shouldn't need any drivers on Mac. In the device info see if the serial number ends in. +FW or +BL. Where did you get it from?


Got it from you :)

It says +FW

Code: Select all
Sparky:

  Product ID:   0x41d0
  Vendor ID:   0x20a0
  Version:   0.02
  Serial Number:   23001B000857324D33303420+FW
  Speed:   Up to 12 Mb/sec
  Manufacturer:   Tau Labs
  Location ID:   0x14100000 / 14
  Current Available (mA):   500
  Current Required (mA):   250


The device Serial: usbmodel1411 appears when connecting the sparky. Nothing really happens when clicking connect except the device drop down graying out and the button changes to "Disconnect"
Attachments
Snip20150414_2.png
Snip20150414_2.png (46.92 KiB) Viewed 5453 times
User avatar
User

peabody124

Posts

1339

Joined

Tue Feb 18, 2014 12:33 pm

Re: Problem connecting Sparky to Mac

by peabody124 » Tue Apr 14, 2015 7:04 pm

Well that's odd then, I'd definitely have set it up on a mac and tested USB. The +FW in the serial number means the firmware is correctly triggering an enumeration which is the only reason I've ever seen this fail. I assume the blue LED is flashing around one hertz?

Are you running any other software? Are you using a USB hub? Anything else plugged into the USB?
User avatar
User

strips

Posts

49

Joined

Sat Sep 20, 2014 9:44 pm

Location

Norway, Åros

Re: Problem connecting Sparky to Mac

by strips » Tue Apr 14, 2015 8:25 pm

peabody124 wrote:Well that's odd then, I'd definitely have set it up on a mac and tested USB. The +FW in the serial number means the firmware is correctly triggering an enumeration which is the only reason I've ever seen this fail. I assume the blue LED is flashing around one hertz?

Are you running any other software? Are you using a USB hub? Anything else plugged into the USB?


Funny. After fiddling with this some days now suddenly GCS comes to life. I was even able to run the Vehicle Setup Wizard.

The only thing I did in between was download a Ubuntu VirtualBox image fire it up and getting the same symptom as in OSX. Quitting VirtualBox, removing a Logitech Unified wireless dongle from the second USB port and voila. Connecting Sparky shows immediatly in GCS.

Still works after putting back the dongle.

Maybe I had some other software running as you are mentioning.

Thanks :)
User avatar
User

peabody124

Posts

1339

Joined

Tue Feb 18, 2014 12:33 pm

Re: Problem connecting Sparky to Mac

by peabody124 » Tue Apr 14, 2015 8:43 pm

Curious. Glad it is working though. If you have issues again I'd repeat the whole unplugging dance.
User avatar
User

strips

Posts

49

Joined

Sat Sep 20, 2014 9:44 pm

Location

Norway, Åros

Re: Problem connecting Sparky to Mac

by strips » Fri Apr 17, 2015 5:22 am

Once in a while connecting, disconnecting, rebooting and just messing about GCS does not recognize Sparky. I'll need to make a dump of System Information USB info and the actual device in OSX to compare the next time it happens.

Not a big problem as I can fix it with disconnecting everything (other USB devices also), restart GSC and connect.
no avatar
User

jerryn

Posts

1

Joined

Fri Oct 16, 2015 2:01 am

Re: Problem connecting Sparky to Mac

by jerryn » Fri Oct 16, 2015 2:09 am

My mac is running 10.9.5 and I use it with Arduino development all the time. I installed GCS to set up the Sparky board. No luck.
The Sparky interface shows up with System Report and the serial port shows up with GCS. I can open the port but communication fails.
I fired up a windows virtual machine and gcs for windows works fine but I prefer to stay in the native os.

Has anyone figured this out yet ?
User avatar
User

peabody124

Posts

1339

Joined

Tue Feb 18, 2014 12:33 pm

Re: Problem connecting Sparky to Mac

by peabody124 » Fri Oct 16, 2015 3:50 am

Can you unplug everything else from usb. That's caused a few issues in the past. Also, maybe erase the flash when in windows vm to make sure no odd settings are in place.
no avatar
User

Laurakep

Posts

9

Joined

Tue Oct 18, 2016 8:10 pm

Location

Russia

Problem connecting Sparky to Mac

by Laurakep » Mon Nov 07, 2016 7:06 pm

Anyone using an Apple Mac to run the software. Wanted to load it up with the VM ware fusion software, but wanted to see if anyone else was running it this way.

___
NEW XRumer 12.0.19: revolutional method in SEO and SMM

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB ® | phpBB3 Style by KomiDesign
cron