Post here for help with your new vehicles setup. Friendly advice on tuning and settings.
no avatar
User

neodimio91

Posts

8

Joined

Mon Feb 22, 2016 12:36 pm

flyingf4 drift problem

by neodimio91 » Tue Feb 23, 2016 2:38 pm

Here the video of what i get with default settings ,i put only throttle and it drift so insane! has someone some tips?
One more thing,during wizard setup i get saving failure and i get this log on DEBUG info

16:21:38[DEBUG]Progress 3 ( 12 )
16:22:38[DEBUG]Transaction timed out when trying to save: "HwCopterControl"
16:22:38[DEBUG]Transaction timed out when trying to save 11 objects.
16:22:38[DEBUG]Finished saving modified objects to controller. Success = false
16:22:38[DEBUG]Progress 4 ( 12 )



[youtube]youtube.com/watch?v=VtEsTL1FlsY&feature[/youtube]
no avatar
User

pug398

Posts

700

Joined

Fri Mar 07, 2014 2:26 am

Re: flyingf4 drift problem

by pug398 » Tue Feb 23, 2016 3:27 pm

Connect the board. Go to the Flight page and make sure as you tilt and rotate the craft the PFD and model view respond correctly. Go to Attitude page and do the calibration. Fly in "Leveling" flight mode to start.
no avatar
User

pug398

Posts

700

Joined

Fri Mar 07, 2014 2:26 am

Re: flyingf4 drift problem

by pug398 » Tue Feb 23, 2016 3:31 pm

You flashed F4 firmware to the board?
Attachments
flyingF4.PNG
flyingF4.PNG (13.8 KiB) Viewed 1476 times
no avatar
User

neodimio91

Posts

8

Joined

Mon Feb 22, 2016 12:36 pm

Re: flyingf4 drift problem

by neodimio91 » Tue Feb 23, 2016 3:50 pm

yes i flashed in rescue mode, as usb connection is called DiscoveryF4 right down corner on the GSC,as a concequence i have to put sbus uart1 enable manually,maybe some settings too?
no avatar
User

pug398

Posts

700

Joined

Fri Mar 07, 2014 2:26 am

Re: flyingf4 drift problem

by pug398 » Tue Feb 23, 2016 4:10 pm

I have not built one so not sure of all the steps. The wiki page https://github.com/TauLabs/TauLabs/wiki ... om-scratch is what I would go by.
no avatar
User

neodimio91

Posts

8

Joined

Mon Feb 22, 2016 12:36 pm

Re: flyingf4 drift problem

by neodimio91 » Tue Feb 23, 2016 4:14 pm

mmm the bootloader where do i find it?( maybe i did it but don't remember :S the firmware is right but on the firmware page if i open the flyingF4 it says me that is not the same version I don't know why ( see attachment)
Now I'm soldering the sensors board so no doubts on it, the circuit is simple i put the discovery F4 connect FRsky through S bus with a transistor to shift voltage level ( on UART1) connect the GY86 and nothing else on the ground control all seems work (exept the setup wizard that fail), so i had to put s bus as uart1 manually, neutral level for each motor,leveling the quad and I did the 6 axis calibration, obviosly i put stabilized 1 as mode and arm condition
Attachments
Immagine.png
Immagine.png (287.63 KiB) Viewed 1453 times
Last edited by neodimio91 on Tue Feb 23, 2016 5:38 pm, edited 1 time in total.
no avatar
User

pug398

Posts

700

Joined

Fri Mar 07, 2014 2:26 am

Re: flyingf4 drift problem

by pug398 » Tue Feb 23, 2016 5:11 pm

It is in the same flight folder. Just the bootloader is the bl.bin file. The bu file is firmware with a bootloader and extractor inside. If you can write tlfw files you can just load and write bu_flyingf4.tlfw and boot. Wait a bit then disconnect/reconnect board and bootloader should connect. If for some reason the firmware uploader gets corrupted you can use loader utility and put board in dfu mode and flash ef_flyingf4.bin to it which is bootloader and flight firmware all together.
no avatar
User

neodimio91

Posts

8

Joined

Mon Feb 22, 2016 12:36 pm

Re: flyingf4 drift problem

by neodimio91 » Tue Feb 23, 2016 5:27 pm

I have only .tlfw files on the C:\Program Files (x86)\TauLabs\firmware , where is the location of the foulder that you posted on the pics?? downloaded the portable version now i see the bin file XCCCCCCCCC
no avatar
User

neodimio91

Posts

8

Joined

Mon Feb 22, 2016 12:36 pm

Re: flyingf4 drift problem

by neodimio91 » Tue Feb 23, 2016 5:44 pm

now seems to work i put it all togheter and I ll see if it works now! my god why that files disappear!!!!!
User avatar
User

peabody124

Posts

1339

Joined

Tue Feb 18, 2014 12:33 pm

Re: flyingf4 drift problem

by peabody124 » Tue Feb 23, 2016 7:16 pm

Echoing my responses on IRC, from your video I have two important questions:

1) when you have it level on the ground does it show up level in GCS? If it thinks it is tilted when sitting level then when it flies it will try to correct that.
2) does it respond to stick input? I'm not sure how good of a pilot you are, but can you hover in place?

If it looks level in 1 and flies responsively in 2, I would consider trying an autotune anyway. The reason is perhaps your ESCs are not well matched and thus it ends up a bit crooked with the default settings while compensating for this.
Next

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB ® | phpBB3 Style by KomiDesign
cron