Discuss and document your current build.

HMF S500 Quad

no avatar
User

icee

Posts

216

Joined

Thu Apr 02, 2015 8:00 pm

Re: HMF S500 Quad

by icee » Wed Aug 26, 2015 3:27 pm

You may need to turn up P/I a little to get through maiden & auto-tune. Our starting values are really conservative.

I suggest you go to P=30/I=25 on the rate loop and go from there-- and it's possible you'll need to turn them up a little more to get flight where it doesn't want to tip over.

You don't need to get it locked in-- just stable enough it doesn't want to tip over and need constant sticks fighting in hover-- to get a good autotune.
no avatar
User

WZ9V

Posts

44

Joined

Fri Jul 24, 2015 6:21 pm

Re: HMF S500 Quad

by WZ9V » Wed Aug 26, 2015 3:48 pm

Thanks for the info, I'll modify the PI values as suggested. So I should basically do some minimal manual tuning to get it somewhat stable before attempting auto tune. Sounds like I have my next step.
no avatar
User

icee

Posts

216

Joined

Thu Apr 02, 2015 8:00 pm

Re: HMF S500 Quad

by icee » Wed Aug 26, 2015 3:52 pm

Yes.

Basically, PIDs that are too low (undercontrol) are better than PIDs that are too high (overcontrol, divergent behavior, runaway). For that reason we have to pick defaults that are on the low side. I think they're still too low for just about all frames and I'll be thumbing through the autotune thread again to turn them up slightly for this release.
no avatar
User

WZ9V

Posts

44

Joined

Fri Jul 24, 2015 6:21 pm

Re: HMF S500 Quad

by WZ9V » Wed Aug 26, 2015 5:35 pm

Good to know. Last time I did this with just the defaults it was with MultiWii and I think their default PIDS are a bit more aggressive. Glad you pointed this out so that now I won't have a WTF moment and know it needs more tuning. I'm moving over from Blade stuff (no tuning) with a smattering of MultiWii until I decided I really want to focus on 32-bit solutions.
no avatar
User

WZ9V

Posts

44

Joined

Fri Jul 24, 2015 6:21 pm

Re: HMF S500 Quad

by WZ9V » Tue Sep 01, 2015 2:03 am

Didn't get that maiden in last weekend. Needed to recreate my setup on the Taranis Plus and then run back through the vehicle setup to ensure it was all correct. Finally got the ESC's to tick over in vehicle setup by resetting the throttle curves in the calibration screen in GCS. Have it all ready to go once I get some time to take it out. Meanwhile I can start reading up on auto tune.
no avatar
User

WZ9V

Posts

44

Joined

Fri Jul 24, 2015 6:21 pm

Re: HMF S500 Quad

by WZ9V » Fri Oct 16, 2015 6:50 pm

Work got busy and I never did get that maiden in. I'm going to upgrade to the new stable that was posted and confirm the setup hoping for a calm day this weekend but early reports don't look good as far as wind. Is there anything in the default vehicle setup I should change before that first flight?
Previous

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB ® | phpBB3 Style by KomiDesign
cron